With the issues in the other bugs fixed I am able to successfully commission a number of Matter devices and read attributes from them. However, when I restart my service and attempt to connect to the devices I previously commissioned again, it almost always fails with an error like "operational error: connect to node 2 failed: driver error: device discovery failed: operational node F52AC107C954E38E-0000000000000002 not found via mDNS". (It does occasionally work, but it seems to work less than 5% of the time.)
If I open avahi-discover I can see all these addresses advertised under _matter._tcp just fine, so it seems to be something to do with how the matter-controller crate does mDNS discovery in this case. As another data point, the same devices also reconnect fine if I use the matc crate instead (though that crate has other limitations, so I'd prefer to use matter-controller).
The same issue happens for all the devices I've tried, and it only seems to happen on re-connection; the initial commissioning works fine most of the time. I'm running on Ubuntu 24.04.4, in case that makes a difference.
With the issues in the other bugs fixed I am able to successfully commission a number of Matter devices and read attributes from them. However, when I restart my service and attempt to connect to the devices I previously commissioned again, it almost always fails with an error like "operational error: connect to node 2 failed: driver error: device discovery failed: operational node F52AC107C954E38E-0000000000000002 not found via mDNS". (It does occasionally work, but it seems to work less than 5% of the time.)
If I open
avahi-discoverI can see all these addresses advertised under_matter._tcpjust fine, so it seems to be something to do with how thematter-controllercrate does mDNS discovery in this case. As another data point, the same devices also reconnect fine if I use thematccrate instead (though that crate has other limitations, so I'd prefer to usematter-controller).The same issue happens for all the devices I've tried, and it only seems to happen on re-connection; the initial commissioning works fine most of the time. I'm running on Ubuntu 24.04.4, in case that makes a difference.